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4.1 Introduction 

 
Data visualization is the graphical representation of information and data, employing visual 

elements like charts, graphs, maps, and dashboards to make complex datasets more accessible 

and understandable. By translating raw data into visual formats, it enables the identification 

patterns, trends, and outliers, facilitating quicker and more informed decision making This 

practice is integral across various fields including business analytics, healthcare, education, and 

journalism where it aids in communicating insights effectively to diverse audiences. In the 

context of big data, visualization tools are essential for analyzing vast amounts of information, 

allowing stakeholders to grasp intricate concepts swiftly and derive meaningful conclusions. 

 

What are Charts and Graphs in Excel ? 

 

Charts and graphs in Excel are powerful tools for data visualization. They help you present and 

analyze data graphically, making it easier to identify trends, patterns, and comparisons. By 

converting numerical data into visual formats, you can communicate complex information 

clearly and effectively. 

 

Uses of Charts and Graphs in Excel 

 

Charts and graphs in Excel affer several advantages 

 

●​ Data Visualization: Transform raw data into visually appealing graphics. 

●​ Comparison Easily : compare different datasets. 

●​ Trend Analysis: Identify trends and patterns over time 

●​ Clarity: Make data insights more accessible and understandable 
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4.1.1 Creating a Simple Chart 

 

Step-by-Step Guide to Creating Different Types of Graphs in Excel 

 

Plotting a Graph in Excel is an easy process. Below is a step-by-step process explaining how te 

make a chart or graph in Excel 

 

Step 1: Create a Dataset 

 

In your excel sheet enter the dataset for which you want to make a chart or graph. We are 

using the following random sales data for different courses for January - March period 

 

Step 2: Select the Dataset 

 

Select the entered dataset by drag and drop or by CTRL+ A 
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Step 3: Go to Insert and Select Recommended Charts 

 

Go to the Insert Tab and in the dropdown select the chart of your choice from the 

Recommended Charts You can click on All charts option if you cannot find your desired chart. 

 

Go to Insert and Select Recommended Charts 

 

There are various types of charts recommended by Excel. You can preview the chart 

before applying it. Select the chart or graph that you desire and click on OK. 

 

4.1.2 Charting Non-Adjacent Cells in Microsoft Excel 
 

In Microsoft Excel, charts are essential tools for visualizing data. While it's common to create 

charts from data arranged in adjacent cells, there are situations where the data you want to 

Include in a chart is located in non-adjacent (non-contiguous) cells or ranges. Excel provides 

methods to handle such scenarios effectively. 

 

Months Sales A Sales B 

January 100 150 

February 120 130 

March 70 140 

April 50 150 

 

Now suppose you want to compare Sales A and Sales B only for January and March using 

column chart. 
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Step 1: Open the File 

Open the file: Non Adjacent_Chart_Example.xlsx 

Step 2: Insert a Blank Chart 

●​ Go to the Insert tab on the ribbon. 

●​ In the Charts group, click Insert Column or Bar Chart. 

●​ Choose Clustered Column→ A blank chart will appear 

Step 3: Open the Select Data Dialog 

●​ Right-click on the blank chart area. 

●​ Choose Select Data. 

Step 4: Add "Sales A" Data 

●​ In the Select Data Source window, click Add. 

●​ In the Edit Series window: 

●​ Series name: Click cell B1 (Sales A). 

●​ Series values: 

●​ Delete what's inside the box. 

●​ Hold down Ctrl and click B2 and B4 (100 and 90). 

●​ Click OK. 

Step 5: Add "Sales B" Data 

●​ Click Add again. 

●​ In the Edit Series window: 

●​ Series name: Click cell C1 (Sales B) 

●​ Series values: 

●​ Hold Ctrl and click C2 and C4 (150 and 170). 

●​ Click OK. 
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Step 6: Add Labels for the X-Axis (Months) 

In the main Select Data Source dialog, click Edit under Horizontal (Category) Axis Labels 

Select cells A2 and A4 (January and March). 

Click OK 

 

Step 7: Finalize the Chart 

Click OK to close the dialog 

You'll now see a chart showing Sales A and Sales B for January and March only even thoug they 

were not in a continuous row or column. 

 

 

4.2 Chart Wizard 
 

The Chart Wizard is a spreadsheet feature that guides users through the process of creating charts 

and graphs. It provides a step-by-step interface to help user's select data and chart types and 

customize various aspects of the chart's appearance depending on the selected data. The Chart 

Wizard is designed to make the charting process more intuitive and accessible. 

 

When users launch the Chart Wizard in Excel, they see a series of recommendations. They 

typically include selecting a range of data to plot, selecting a chart type (e.g. bar, line, ple, or 

stock chart), specifying chart parameters such as headings and axis labels, and additional 

customizations as needed. 
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4.2.1 Creating a Chart Using the Chart Wizard in Microsoft Excel 

 

How to use Chart Wizard? 

 

In ONLYOFFICE Spreadsheet Editor the Chart Wizard is activated by the Recommended Charts 

button on the Insert tab 

 

Once you click, you will see recommendations of the ready-made charts and their previews. 

 

Create a new chart using Chart Wizard 

 

Let's create a chart based on our table. 

 

Step 1: Select the cell range that contains the data you wish to use for the chart 

 

Step 2: Go to the Insert tab of the top toolbar and click the Recommended Chart icon. You will 

see a window with ready graphs based on your data 

Step 3: Switch between the recommended chart types to see what the chart will look like. You 

can also use the tabs on the left to preview other chart types 

 

Step 4: Once you have selected the type of chart or graph you want, click OK to insert the chan 

into the spreadsheet. 

 

Step 5: Place the chart in the desired position in the sheet and customize additional parameters in 

the right side toolbar if necessary 
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Customize the chart size and style. In the parameters, it is also possible to change the displayed 

data without deleting the chart itself. To do this, use the Select data function. 

 

Consult the ONLY OFFICE Help Center to learn about all the possibilities of working with 

charts in Spreadsheet Editor. 

 

After you have configured all the settings, your chart is ready 

 

Replace the ready chart with Chart Wizard recommendations 

 

Suppose you already have a chart in your spreadsheet, but you want to improve it to visualize the 

data more clearly. In this case, Chart Wizard will help you to choose the best option. You can 

save time by not having to go through all the possible options. 

 

To do this, click on the ready chart and go to the Insert tab Recommended Chart. 

 

In the window that opens, select the chart type that suits you best among the options that appear 

as icons in the upper row. 

Click OK and the chart will be replaced with a new one with the same size and style. 

 

4.2.2 Moving an Embedded Chart 

 

What is an Embedded Chart? 

 

Embedded Chart = A chart inside your worksheet. 

 It's part of your Excel sheet and appears along with your data, rather than being on a separate 

Page. 
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How to Move the Chart? 

 

1. Click on the Chart: 

 

When you click on the chart, it gets selected. You'll see a border around it (like a box). Th border 

helps you know the chart is ready to be moved. 

 

2. Hover Over the Border: 

Move your mouse to the edge of the chart. You should see your cursor change into a four headed 

arrow (like a plus sign or cross). 

The four-headed arrow means you can move the chart. 

3. Click and Drag: 

Now, click and hold the mouse button on the chart, and drag it anywhere on the sheet. 

You can move the chart to a new location (eg, top-left corner, bottom-right corner). 

4. Let Go of the Mouse: 

Once the chart is where you want it release (let go of) the  mouse button The chart will stay in 

the new place. 

Why Move a Chart? 

 

Moving a chart is helpful when you need to make space for more data or want to organize things 

neatly it's like dragging a picture around in a document: 
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4.2.3 Sizing an Embedded Chart 

 

Sizing a chart typically means adjusting the dimensions (height and width) of a chart or graph to 

make it fit a specific space or improve its readability 

How to Resize an Embedded Chart in Excel ? 

1. Manual Resizing 

Steps: 

●​ Select the Chart: Click on the chart to activate it 

●​ Resize Handles: You'll notice small circles or squares (handles) appear on the corners 

and edges of the chart 

●​ Adjust Size: Click and drag these handles to resize the chart: 

●​ Corner Handles: Resize bath width and height proportionally 

●​ Side Handles: Resize width or height independently. 

Tip:  Holding the Shift key while dragging a comer handle maintains the chart's aspect ratio 

 

2. Setting Exact Dimensions via the Ribbon 

Steps: 

●​ Select the Chart Click on the chart to select it 

●​ Navigate to the Format Tab: Go to the Format tab on the Ribbon 

●​ Enter Dimension 

o​ In the Size group. Input your desired Height and Width values 

o​ Press Enter to apply the changes. 

Example: 

●​ Height : 4 Inches 

●​ Width: 6 inches 
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3. Using the Right Click Menu for Size and Properties 

Steps: 

●​ Right Click on the Chart: Right-click anywhere on the chart area 

●​ Format Chart Area: Select Format Chart Area from the context menu. 

●​ Adjust Size 

o​ In the Format Chart Area pane go to the Size & Properties tab 

o​ Under Size, adjust the Height and Width as needed 

o​ Optionally check Lock aspect ratio to maintain proportional resizing 

 

Tips for Effective Chart Resizing 

●​ Maintain Aspect Ratio: To prevent distortion, ensure the Lock aspect ratio option is 

enabled. 

●​ Align with Cells: If you want the chart to align with specific cells, hold down the Alt key 

while resizing. This will snap the chart to the gridlines, helping it fit neatly within the 

desired cel range 

●​ Consistent Sizing Across Sheets: If you need the same chart size across multiple sheet, 

consider creating a template chart and copying it to other sheets. 
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4.3 Changing the Chart Type 
 

Charts are used to show data visually. Sometimes, you may want to change how the data is 

displayed. For example, from a bar chart to a line chart, depending on what you want to show. 

 

Why change the chart type? 

●​ To make the data easier to understand. 

●​ To highlight trends or comparisons 

●​ To suit the type of data you have. 

●​ How to Change the Chart Type (in Excel or Google Sheets)? 

Steps: 

●​ Click on your chart (select it). 

●​ Find and click on "Change Chart Type" (usually in the toolbar or chart editor) 

●​ Choose the chart type you want-like Line, Pie. Column. Area, etc. 

●​ Click OK or Apply and your chart updates! 

 

Example: 

Month Sales 

Jan 100 

Feb 140 

March 120 

April 160 

 

Let's say we have this data: First, you create a bar chart to show it. But later, you want to show 

the trend of sales over time, so you change it to a line chart 
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Here is a real-time image that shows how the same data can be visualized using two different 

chart types in Excel-style visuals: 

●​ On the left, you see a Bar Chart 

●​ On the right, the same data is shown as a Line Chart 

This is exactly what happens when you change the chart type in Excel using the "Chang Chart 

Type” option. 

4.3.1 Changing the Way Data is Displayed 

Data can be shown in many different visual formats like bar charts, line graphs, or pie chart, 

Choosing the right way to display your data helps people understand it better 

Why should we change the way data is displayed? 

Sometimes, changing the chart or format helps the data 

●​ Make more sense. 

●​ Show something important, like a trend or comparison 

●​ Match what you want people to focus on. 
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Think of it like telling a story: you want the right picture to go with your message 

Examples of How the display can change the message 

Let's say you have this data: 

Month Sales 

Jan 100 

Feb 140 

March 120 

April 160 

You can show In different ways: 

1.​ Bar Chart 

●​ Each bar shows the sales for one month. 

●​ Easy to compare months side by side. 

●​ Helps answer: "Which month had the highest sales?" 

2. Line Chart 

●​ Connect the points to show how sales change over time. 

●​ Helps you see the trend going up or down 

●​ Good for time-based data (weeks, months, years) 

3. Pie Chart 

●​ If you want to show how much each month contributes to the total sales, a pie chart 

can help. 

●​ Not great for time trends-better for showing parts of a whole 
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How to Change the Chart Type ? (Excel or Google Sheets) 

 

●​ Click your chart to select it. 

●​ Look for "Change Chart Type 

●​ In Excel it's under the Chart Design tab 

●​ In Google Sheets: it's in the Chart Editor. 

●​ Pick a new chart: Bar, Line, Pie, Column, Area, etc. 

●​ Click OK or Apply. 

●​ Your chart will now display the same data in a new way. 

4.3.2 Legend in a Chart 

A legend in a chart is a visual guide that helps users understands the meaning of various 

elements in the chart. It typically shows the colors, patterns, or symbols used to represent 

different data series or categories. 

Example: In a line chart showing monthly sales for 3 products 

The legend might look like: 

o​ Product A 

o​ Product B 

o​ Product C 

Each colored line on the chart matches the corresponding product name in the la helping users 

know which line represents which product. 
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Key Features of a Legend: 

●​ Usually placed at the top, bottom, or side of a chart. 

●​ Can be interactive in some tools (eg. clicking a legend item can toggle a data series 

on/off) 

●​ Improves readability and interpretability of multi-series charts. 

Moving the Legend in a Chart 

When you make a chart in Excel or Google Sheets, it often includes a legend a small box 

explains what the colors or lines in the chart represent. For example: 

●​ Blue Girls 

●​ Red Boys 

●​ Green Total 

●​ This is super helpful when you're showing more than one group or data series in your 

chart. 

Why Move the Legend? 

Sometimes, the legend might: 

●​ Be blocking part of the chart 

●​ Look awkward where it is 

●​ Be better placed closer to the title or outside the chart area 

By moving the legend, you make your chart: 

●​ Easier to read 

●​ More organized 

●​ Better for presentations or reports 
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Imagine presenting your chart in class and someone can't see the bars because the legend in the 

way that's when moving it helps! 

Where can you move the legend? 

Position When to use 

Right (default) Good for most charts with space on the side 

Top When you want the legend near the title 

Bottom Works well when space is tight at the top 

Left Useful for charts with left-aligned focus 

Inside Chart Only if it doesn't block important data 

 

How to Move the Legend? 

In Excel: 

1 . Click the chart to select it 

2. Click on the legend box. 

3. Go to the Chart Design tab 

4 . Click "Add Chart Element" > Legend > Choose Position (Top, Bottom, Left, Right) 

Example: 

Let's say you are showing the test scores of boys and girls in 4 subjects 
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Subject Boys Girls 

Math 90 95 

English 80 85 

Hindi 70 80 

Art 85 90 

You create a bar chart with two colors blue for boys, pink for girls. 

If the legend is siting over the bars, your classmates won't see the full chart. You can the legend 

to the bottom, below the chart, so it's out of the way and still helpful. 
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4.4 Introduction to Chart Formatting 

Charts are powerful tools that transform raw data into visual stories, making compare 

information easier to understand Proper formatting enhances clarity, emphasizes key insist and 

makes your data presentations more engaging. 

4.4.1 Adding Chart Elements 

Essential Chart Components 

●​ Chart Title: Describes the overall purpose of the chart 

●​ Axis Titles: Label the horizontal (X axis) and vertical (Y-axis) axes 

●​ Legend: Identifies different data series in the chart. 

●​ Data Labels: Display specific values for data points. 
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●​ Gridlines: Enhance readability by aligning data points 

Adding Elements in Excel 

●​ Create a chart 

●​ Select data for the chart. 

●​ Select Insert >  Recommended Charts 

●​ Select a chart Design  on the Recommended Charts tab, to preview the chart 

●​ Select a chart 

●​ Select OK 

●​ Add a trendline 

●​ Select a chart 

●​ Select Chart Design > Add Chart Element 

●​ Select Trendline and then select the type of trendline you want, such as Linear, 

Exponential, Linear Forecast, or Moving Average 

Format your chart using the Format task pane 

Select the chart element (for example, data series, axes, or titles), right-click it, and click Format  

<chart element>. The Format pans appears with options that are tailored for the selected chart 

element. 

Clicking the small icons at the top of the pane moves you to other parts of the pane with men 

options. If you click on a different chart element, you'll see that the task pane automatically 

updates to the new chart element. 

For example, to format an axis: 

1. Right-click the chart axis, and click Format Axis. 
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2. In the Format Axis task pane, make the changes you want 

You can move or resize the task pane to make working with it easier. Click the chevron the upper 

right. 

●​ Select Move and then drag the pane to a new location 

●​ Select Size and drag the edge of the pane to resize it 

 

 

 

 

 

Format your chart using the Ribbon 
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1. In your chart, click to select the chart element that you want to format. 

2. On the Format tab under Chart Tools, do one of the following 

 

●​ Click Shape Fill to apply a different fill color, or a gradient, picture, or texture to the chart 

element 

●​ Click Shape Outline to change the color, weight, or style of the chart element. 

●​ Click Shape Effects to apply special visual effects to the chart element, such as shadows. 

bevels or 3 D rotation. 

●​ To apply a predefined shape style, on the Format tab, in the Shape Styles group, click the 

style that you want. To see all available shape styles, click the More button 

●​ To change the format of chart text, select the text, and then choose an option on the mini 

toolbar that appears. Or, on the Home tab, in the Font group, select the formatting that 

you want to use. 

To use WordArt styles to format test, select the text, and then on the Format tab in the  WordArt 

Styles group, choose a WordArt style to apply To see all available style, click the More button 

4.4.2 Formatting Text in Charts 

●​ Change Font Style and Size: 

1.​ Click on the text element (eg, chart title) 

2.​ Right click and select Font 
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3.​ Choose the desired font, style, and size 

Change Text Color: 

1. Select the task element 

2. Use the Home tab to choose a new text color 

Why format text in charts? 

Text in charts includes titles, axis labels, legends, data labels, and other annotation Formatting 

helps: 

●​ Improve clarity and readability 

●​ Highlight important values or categories 

●​ Maintain a professional look in reports and presentations 

Text elements you can format in charts 

Text Element Example 

Chart Title "Monthly Sales Report" 

Axis Titles X-axis. "Month", Y-axis "Revenue () 

Legend Text Series names like "Product A", "Product B” 

Data Labels Values displayed on bars, lines, or slices 

Category Labels Axis categories like "Jan", "Feb", etc 

How to Format Chart Text in Excel: Step-by-Step? 
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Step 1: Select the Chart 

Click once on the chart to activate it. 

Step 2:  Select the Test Element 

Click directly on the text you want to format 

●​ Chart Title 

●​ Axis Title  

●​ Legend 

●​ Data Label 

●​ Category Label 

Once selected, a border appears around the text element 

Step 3 : Apply Formatting Options 

Use either of the following 

Method 1 : Right-click Format [Text Element] 

A sidebar appears with text and fill formatting options 

Method 2: Use the Home tab 

Apply font styles, sizes, colors, and alignment from the ribbon 

Common Formatting Options 

1. Font Style and Size 

●​ Change font type (Arial, Calibri, etc) 
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●​ Adjust font size for visibility 

●​ Use bold, italic  or underline to emphasize 

Example :Chart Title in bold and 14 pt size 

2.​ Font Color 

●​ Use dark colors for not on light backgrounds and vice versa 

●​ Highlight important data in red or green 

Example : Use red test for negative sales growth labels​  

 

 

 

3.​ Text Fill and Outline 

       In the Format pane: 

●​ Text Fill: Solid, gradient, pattern, or picture Bill 

●​ Text Outline: Border around text (color and thickness) 

Example: Add a white outline to black test on a dark chart background. 

4. Text Alignment 

●​ Horizontal Alignment : Left, Center, Right 

●​ Vertical Alignment:  Top, Middle, Bottom 

●​ Text Direction:  Horizontal, Rotated, Stacked 
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Example: Rotate Y-axis title to vertical direction for compact display 

5. Wrap Text and Resize 

●​ Resize the chart text box to fit longer titles. 

●​ Use wrap text for multi-line labels. 

6. Add or Edit Text 

●​ Click on any chart element (eg, chart title) 

●​ Press F2 or double-click → Enter your custom text 

Example: Change "Series 1" to "Rainfall (mm)" 

 

 

Example: Formatting a Sales Chart 

Task : You created a column chart showing monthly sales 

Apply the following: 

1. Set chart title to bold 16 pt, blue color. 

2. Change Y-axis title to "Sales ($)", 12 pt. Italic 

3. Rotate X-axis labels by 45 degrees for readability. 

4. Format data labels in red font with white background 

Steps: 
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1. Click on chart title � Use Home tab �Bold, Blue, 16 pt. 

2. Click Y-axis title→  Right-click → Format Axis Title→  Italic, 12 pt. 

3. Click X-axis→  Format Axis Text direction → Rotate 45° 

4. Click on data labels→  Format Data Labels → Font: Red, Fill: White 

Final chart: Visually appealing readable, and presentation-ready. 

Best Practices 

Keep fonts consistent � Use same font style across the chart 

Use colors sparingly → Emphasize only what's necessary 

Avoid clutter  → Too much text can confuse the reader 

Use appropriate size → Ensure all labels are legible 

4.4.3 Formatting and Aligning Numbers 

Number Formatting in Excel 

Format Axis Numbers: 

1. Click on the axis to select it 

2. Right-click and choose Format Axis 

3. In the Format Axis pane, select Number 

4. Choose the desired format (eg. Currency, Percentage). 

 

Department of Computer Engineering , Faculty of Polytechnic, YTC, Satara|                                               27 

 

 



 
5. Right-click on the axis labels 

6. Select Format Axis 

7. Adjust alignment settings under Alignment 

Why format and align numbers 

Formatting numbers makes data 

●​ Easier to read and interpret. 

●​ More professional in appearance 

●​ Suitable for different types of data (eg, currency, percentage, scientific) 

●​ Aligned properly for better visual comparison in tables or charts 

 

What can you format in numbers ? 

●​ Number type → Currency, Percentage, Fraction 

●​ Decimal places→ 23.5-23.50 

●​ Negative number style → (123) -123, red color 

●​ Alignment → Left, Center, Right 

●​ Thousand separator → 1000000 → 1,000,000 

How to Format Numbers in Excel: Step-by-Step? 

Step 1 : Select the Cells 

Open your Excel worksheet 

Select the cell(s) or column(s) with numbers you want to format. 
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Step 2 : Open Format Cells Dialog Box 

There are two main ways: 

Method 1: Right click-Format Cells 

Method 2: Use the Home tab In the Number group Click the small arrow is (bottom-right 

corner) 

Number Formatting Options 

In the Format Cells dialog box→ Select the Number tab 

1.​ General 

Default format→  displays numbers as you type them. 

 

2.​ Number 

●​ Customize decimal places. 

●​ Choose whether to use comma separator 

●​ Choose format for negative numbers. 

Example: 

12345.678→ 12,345.68 (2 decimal places) 

3.​ Currency 

Adds a currency symbol (P. 5. €. etr.) 

Custom decimal places and symbol placement 
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Example: 

$12343-$1,234.50 

4.​ Accounting 

Similar to currency but aligns currency symbols neatly in column 

5.​ Percentage 

Multiplies the value by 100 and adds a% sign. 

Example: 0.25-25% 

6.​ Scientific 

Displays numbers in exponential notation .             Example: 12345678→1.23E+07 

 

Aligning Numbers in Excel 

Numbers can be aligned for better presentation, especially in tables 

Steps to Align Numbers: 

●​ Select the cells with numbers 

●​ Go to the Home tab Look for the Alignment group 

●​ Use the following options 

o​ Left Align → Align number to the left. 

o​ Center Align → Align number to the Center. 

o​ Right Align → Align number to the Right . 
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o​ Top / Middle / Bottom Align →Vertical Alignment of tall cells. 

Wrap Text and Merge 

o​ Wrap Text:  Adjusts the text to fit inside the cell without everlossing 

o​ Merge & Center: Combines multiple cells and centers the content 

Example Activity: Format a Sales Table 

Scenario: You have monthly sales data 

Month  Sale 

Jan 20500 

Feb 18500 

 

 

Task : 

●​ Format sales column as currency ($ , 2 decimals) 

●​ Right align the sales valurs 

●​ Center align the month 

Steps: 

1. Select the Sales column Right-click Format Cells Currency. 2 decimals 

2. On Home tab Click Right Align 
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3. Select the Month column Click Center Align 

Result: Neat and professional looking table 

4.4.4 Formatting the Plot Area 

In Excel: 

1 Click on the plot area in select it 

2. Right-click and choose Format Plot Area 

3. In the Format Plot Area pane, adjust fill color, border style , and effect . 

What is the Plot Ares? 

●​ The Plot Area in an Excel chart is the central region where the actual data (bars Lines 

,Slices, etc) is displayed. It is bounded by the axes and surrounded by the chart area. 

 

●​ Think of it as the "canvas" where your data comes to life 

Why Format the plot area? 

Formatting the plot area improves: 

●​ Visual appeal 

●​ Data clarity 

●​ Focus on key patterns or trends 

●​ Readability in printed or digital reports 

How to format the plot area in excel: Step-by-Step ? 
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Step 1 :Select the Plot Area 

1.​ Click once on the chart 

2.​  Then, click inside the area where the data is plotted (not on the border or title) 

3.​ You should now see a boundary box around the plot areas only. 

Step 2: Open Format Options 

1.​ Right-click on the selected plot area. 

2.​ Choose "Format Plot Area..." from the context menu. 

3.​ A sidebar titled Format Plot Area will appear on the right 

 

 

 

Formatting options in the plot area 

Let's go through the most common formatting changes you can apply: 

1.Fill Options 

Under the Fill & Line (paint bucket) icon: 

No Fill: 

●​ Removes all background color. 

●​ Use when printing on colored paper or to keep charts minimal 

Solid Fil 
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●​ Applies a single color 

●​ Best for clear, uniform backgrounds 

Gradient Fill 

●​ Blends two or more colors. 

●​ Gives a modern or stylized appearance 

●​ Can customize direction, angle color stops 

Picture or Texture Fill: 

●​ Uses an image or built in texture 

●​ Good for thematic charts (eg, soil texture for geology data) 

Pattern Fill: 

Dots, stripes, grids suitable for black-and white prints. 

2. Border Options 

Still under the Fill & Line tab: 

Solid Line: 

Outlines the plot area with a visible border 

Dashed Line: 

Makes the border subtie 

Change Color and Width: 

Set a custom color and adjust line thickness. 
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Tip: Use a border if your chart has a white background and might blend with the rest the sheet 

3. Shadow, Glow & 3D Format 

Under the Effects (pentagon icon) tab 

Shadow: 

Adds depth; helps charts stand out on reports 

Glow: 

Highlights the chart boundaries 

Soft Edges/3D Format : 

More stylized, useful for presentations 

 

Note: Avoid excessive 3D effects in technical reports 

4.4.5 Formatting Data Markers 

In Excel 

1.​ Click on a data series (eg. bars, lines, or points) to select it, 

2.​ Right-click and choose Format Data Series 

3.​ In the Format Data Series pane, adjust marker options such as shape, size, and color. 

What are Data Markers? 
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Data markers are the individual visual symbols (bars, columns, points, slices, etc.) that 

represent data values on a chart. 

In a column chart: data markers are the vertical bars. 

In a line chart: data markers are the dots (or shapes) on the line 

In a pie chart : data markers are the slices 

In a scatter plot: data markers are the plotted dots 

Why format data markers? 

Formatting helps to: 

●​ Highlight Important data points (eg, highest or lowest) 

●​ Differentiate between data series 

●​ Improve chart readability and appeal 

●​ Emphasize trends or categories 

 

How to format data markers in excel: Step-by-Step ? 

Step 1:Select the Chart 

●​ Click on the chart where your data is displayed (eg. column chart or line chart 

Step 2:Select the Data Marker 

●​ Click on one of the data points (eg, a column/bar or point on a line). 

●​ To select all data markers in the series, click once. 
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●​ To format only one marker, click again on that specific marker 

Step 3: 

●​ Open Format Data Series 

●​ Right-click on the selected marker or series 

●​ Choose "Format Data Series "from the menu 

●​ A sidebar titled Format Data Series will appear. 

Now you are ready to format! 

Options for Formatting Data Markers 

1. Fill and Border (for bar/column markers) 

Under the Fill & Line tab paint bucket icon) 

●​ Solid Fill: Choose a single color for bars/columns 

●​ Gradient Fill Blend two or more colors for a stylish look 

 

●​ Picture or Texture Fill: Insert an image or texture (eg, logo or theme) 

●​ Border Line: Add colored outlines around bars/dots 

2. Marker Options (for line and scatter charts) 

Under the Marker Options tab 

●​ Built-in Marker Types: Circle, square, triangle, star, diamond, etc. 

●​ Market Size: Increase of decrease size (eg. 5pt. 10pt) 

●​ Marker Fill Color: Change inside color of the marker 
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●​ Marker Border Color : Customize the outline color and thickness 

4.4.6 Formatting Charts in Excel 

One of the major uses of Excel is to create different types of charts for a given data set. E 

provides us with a lot of modification options to perform on these charts to make them no 

insightful 

In this article, we are going to see the most common "Formatting performed on charts a suitable 

example shown below 

Example: Consider the performance of a batsman in a T20 match. The data sat contains De runs 

scored by the batsman in various matches 

Match Run scored 

M1 50 

M2 60 

M3 56 

M4 75 

●​ Now we will insert a bar chart using the above table. To insert a bar chart 

Select dataset  →  Click on Insert  →  Chart Sets Pop Down→2-D column 

●​ The key steps to format anything on the chart is 

o​ Select the part of the chart which needs to be furmatted 

o​ Right-click on it and select "Format". The format window will open. 
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1. Formatting the Chart Title 

Select the Title →  Right Click on it  →  Format Chart Title .  

 

In the Format Chart Title window, you can change the Font color, add Borders surrounding the 

title and various other modifications can be done. You can also rename the title  by simply 

selecting and retyping a new name. 
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2. Formatting Axis Titles 
 
You can add the axis title by using the "+" button in the top right corner of the chart 
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Now, rename the X-axis and Y axis by selecting them You can edit the appearance of the axis 
title by right clicking on it and selecting "Format Axis Title". 
 
3. Formatting Data labels 
You can add Data Labels by using the "+" button on the top right corner of the chart..  
 

 

Department of Computer Engineering , Faculty of Polytechnic, YTC, Satara|                                               41 

 

 



 

 
Now open the Format Data Labels Window and can change the Font color, size, alignment, and 
many other options. 

 
4.​ Formatting Data Series 
 
You can change the color of the bar charts by selecting them and then open the "Format Data 
Series" window . By default, on left clicking once on any of the bars all the data sets bar will be 
selected. If you want to select only one of these bars, left-click twice on the bar which i be 
formatted. 
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